Dokumentation von openBCM

Altes Hobby Packet Radio… neu gestartet.

Nachdem ich Jahre das alte Hobby „Packet Radio“ in der sprichwörtlichen „Ecke“ habe liegen lassen, will ich nun einen neuen Versuch starten das Ganze mit neuem Leben wieder zu erwecken.

Mittlerweile ist man nicht mehr an alte PCs unter DOS gebunden und ein alter RaspberryPi ist sicherlich noch in der Schublade um zum neuen Leben erweckt zu werden.

Bei der genaueren Recherche bin ich auf die folgenden Punkte zur Beachtung gestoßen:

  • das Filesystem soll auf einer SSD (mSata etc.) laufen. Die SD-Card hat nur eine eingeschränkte Lebensdauer.
  • das ganze System muss eventuell für neue Anpassungen neu kompiliert werden. Teilweise haben sich die Voraussetzungen stark verändert.

Der Kreis der dazu möglichen Rechner wird durch diese Parameter eingeschränkt.

Meine ersten Versuche habe ich auf einem RasPi3 mit Adapter für eine mSATA gemacht. da ich aber weitere Dinge versuchen möchte bin ich dann doch auf einen Lenove ThinkCentre M625q umgestiegen.

Mein Wunsch war es einen INET-Node mit Mailbox zu betreiben. Spätere Erweiterungen sollten dann dazukommen, wie zum Beispiel APRS-Igate und HF-Anbindung.

Bei der Suche im Internet nach geeigneter Software zuerst bei einem RasPi-Image auf dem forum.packetradio-salzwedel.de von Manuel (MD2SAW via CB0SAW) hängen geblieben.

Linux-Update… die folgenden Pakete sind zurückgehalten worden

gefunden bei https://wiki.byte-welt.net/wiki/Linux_Update_-_Die_folgenden_Pakete_sind_zurückgehalten_worden

Neulich wollte ich das Raspbian auf auf meinem Raspberry Pi einem Update unterziehen. Eigentlich keine große Sache. Terminal geöffnet, SSH-Verbindung hergestellt und die Befehle für das Update der Softwarepaketlisten und das Update installierter Pakte auf eine neuere Version abgesetzt:

sudo apt update && sudo apt upgrade

Nach der Passworteingabe erschien dann auf dem Bildschirm diese Meldung:

Die folgenden Pakete sind zurückgehalten worden:
  <Name der zurückgehaltenen Pakete>

Die Liste der Pakete gibt an welche Pakete zurückgehalten wurden, also nicht in das Update einbezogen.

Diese Meldung weist darauf hin, dass es neue Versionen von Paketen mit Abhängigkeiten gibt, oder dass sich Abhängigkeiten geändert haben, die ebenfalls mit installiert werden müssen. Da ich aber nur ein einfaches Update bestehender Pakete angefordert hatte, erhielt ich von Linux diese Information.

Um nun das komplette System auf den aktuellsten Stand zu bekommen, tippt man nun folgenden Befehl in die Kommandozeile:

sudo apt-get update && sudo apt-get dist-upgrade